Recent FireFox release does not support Java

The recently released commercial version of FireFox (v52) no longer supports the Java plugin. Java is required for some commonly used Caltech applications, including Oracle and Kronos Timekeeping. If you need to use a Java-supported version of FireFox, please download and install the ESR (Extended Support Release) version from this link.

Note that the Kronos Timekeeping Limited version does not require Java. Unless you are using Payroll Administrator (PAM) functions, you can simply use the Limited version for most timekeeping tasks.

Also note that Managed Computing customers already have the ESR version of FireFox installed. For questions, please contact the Help Desk (x3500, help@caltech.edu, https://help.caltech.edu).